Zypper на Ubuntu

Я пытаюсь установить пакеты с помощью zypper, но Amazon server, на котором работает Ubuntu, похоже, не установлен zypper. Как я могу установить вывод?

код: zypper install git gcc gcc-c++

ошибка:

> unsupported locale setting
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/CommandNotFound/util.py", line 24, in crash_guard
    callback()
  File "/usr/lib/command-not-found", line 69, in main
    enable_i18n()
  File "/usr/lib/command-not-found", line 40, in enable_i18n
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python3.3/locale.py", line 541, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
0
задан Jonathan Landrum 2013-07-30 18:04:01
источник

2 ответов

zypper-менеджер пакетов suse.

Ubuntu использует АПТ (на любой вкус. aptitude, apt-получают, etc.).

вы могли бы быть в состоянии найти версию zypper для Ubuntu, но я бы не ставил на это... и я бы не советовал тебе даже пытаться. Просто используйте один из инструментов семейства apt.

в стороне, что ошибка не имеет прямого отношения к проблеме zypper и на самом деле является проблемой в "команда не найдена" помощник, что Ubuntu пытался использовать для скажу вам, что установить, чтобы получить команду, которую вы хотели. Я понятия не имею, почему это происходит навскидку, но это, безусловно, местная проблема.

5
отвечен Etan Reisner 2013-07-30 18:07:02
источник

вы также можете просто установить Zypper на Ubuntu:

sudo apt install zypper

ссылки: Zypper в Launchpad

0
отвечен Jonathan Landrum 2017-01-18 19:26:39
источник

Другие вопросы linux ubuntu package-management zypper

X