Похожие вопросы

Cygwin-не может или не создает файлы профилей пользователей - / home / User/
ssh-X с cygwin в Windows: "не удается получить доступ к дисплею X"
Добавить псевдоним.mylongwebsiteaddress в конец строки в cygwin
запуск приложений X window с помощью Cygwin+Xming или CygwinX в 64-разрядной версии Windows 7?
Cygwin-gcc не находит включаемые файлы
Неустранимая ошибка Cygwin не удалось настроить ssh-host-config
Cygwin в-сио-автобус-Launcher и xwin-кода валюты XDG-меню высокой нагрузке
Не удается найти хороший исполняемый файл оболочки Cygwin
Отменить изменения setfacl
Как удалить / переустановить cygwin, чтобы использовать sshd?
Ошибка шпатлевки: операция / bin / bash не разрешена при подключении к Cygwin sshd
В чем разница между подсистемой Windows для Linux (WSL), Cooperative Linux (coLinux) и Cygwin?
Проблема при установке MySQL через Cygwin на Windows 10 " Ошибка при загрузке общих библиотек"
Rsync и Cygwin на основе резервного копирования на Windows дает разрешение отказано ошибки
Virtualbox: запустить vboxmanage на хосте windows через SSH?

установка библиотек для cygwin

Я хочу установить эти библиотеки в cygwin, как это сделать? все они доступны в среде cygwin или только в linux?

  • g++ - версия 4.4
  • graphviz
  • его
  • plotdrop
  • libboost версия 1.38
  • libgsl0-dbg
  • libgsl0-dev
  • libgsl0ldbl
5
задан quack quixote
источник

1 ответов

вот официальный Cygwin Список Пакетов. Сюда входят все пакеты, которые можно установить с помощью программы установки Cygwin (ссылке), и позволяет искать и рассматривать содержание пакета прежде чем вы установите его.

обратите внимание, что Cygwin не обязательно использует одинаковые имена пакетов (например,libgsl0-dev, etc), которые используют другие дистрибутивы Linux.

  • G++ и В4.4: последний GCC Cygwin - gcc4-4.3.4-3 (Примечание отдельный gcc4 имя пакета; нормальное gcc пакет версии 3.4.4). Если вам нужна новая версия, вам придется установить из источника.
  • graphviz: недоступно в пакете Cygwin(?); установите Windows версии
  • его: последний пакет gnuplot-4.2.4-1
  • plotdrop: недоступно в пакете Cygwin(?); установить из источник
  • libboost: последний пакет повышение-1.33.1-4 (и соответствующие им boost-devel пакет); для более поздней версии, установить из источника
  • gsl: последний пакеты gsl-1.13-2 (DLL времени выполнения),gsl-devel-1.13-2 (заголовочные файлы, libgsl.а и т. д.), gsl-apps-1.13-2 (утилиты GSL) и gsl-1.13-2-src (источник) доступны. нет dbg package (который обычно содержит отладочные символы для библиотек или программ в пакете); для этого вы, вероятно, захотите захватить исходный код и скомпилировать свою собственную версию.
4
отвечен quack quixote 2010-03-19 16:04:36
источник

Другие вопросы cygwin installation libraries linux