Как обновить Rails до последней версии?

Я бегу на OSX снежного барса. Использование ruby -v Я вижу, что у меня 1.8.7 и с помощью rails -v У меня 2.3.5

когда я пытаюсь gem обновить рельсы я получаю следующую ошибку:

bundler требует RubyGems версии > = 1.3.6

5
задан slhck
источник

4 ответов

Я предлагаю использовать rvm вместо того, чтобы пытаться возиться с ruby, который поставляется по умолчанию с Mac os

1
отвечен 2011-05-14 06:00:04
источник

сообщение об ошибке вы получаете, потому что новая версия Rails требует более новую версию gem чем у вас. Вы можете обновить gem такой:

gem update --system

возможно, Вам понадобится sudo если вы используете систему gem. Вы можете проверить версию gem, запустив:

gem -v

после того, как это будет сделано, и вы можете подтвердить свою версию gem, по крайней мере 1.3.6, вы должны быть в состоянии запустить:

gem update rails
2
отвечен Jonathan Tran 2011-05-14 07:11:35
источник

из моего комментария, вы можете обновить rails этой командой (надеюсь):

sudo gem install rails
0
отвечен Blender 2011-05-14 06:01:03
источник

Я не знаю, если у вас есть варево или Macport:

Если у вас есть Brew installled, то вы используете следующую команду для установки:

sudo gem install rails

или

brew gem install rails

пожалуйста, пройдите по этой ссылке:

http://hivelogic.com/articles/compiling-ruby-rubygems-and-rails-on-snow-leopard/

0
отвечен Deepak Lamichhane 2011-06-26 10:51:33
источник

Другие вопросы ruby-on-rails