Где найти iwlwifi-8000-8.ucode

у меня есть последняя версия Debian, 8.6 с официального сайта и когда я установить его, я получаю сообщение об ошибке говорящее iwlwifi-8000-8.ucode отсутствует.

после прочтения Debian 8 iwlwifi-8000-8.отсутствует ucode Я пошел на предложенный сайт и у меня есть водитель, но это iwlwifi-8000C-13.ucode. В этом ответе также говорится об обновлении ядра, но я предполагаю, что у меня есть последняя версия.

как говорится в названии-где взять iwlwifi-8000-8.ucode?. В качестве альтернативы, как я могу новую версию ядра, если есть более новая версия.

5
задан Community
источник

1 ответов

проблема

С эта страница Вики Intel, я полагаю, что ваша карта Wi-Fi имеет любой из этих чипсетов: Intel® Wireless 8260 или Intel® Wireless 4165, и они, по-видимому, поддерживаются начиная с версий ядра 4.1 и 4.3, соответственно, в то время как на складе Debian 8.6 имеет ядро 3.16.

тот факт, что модуль просит userspace загрузить iwlwifi-8000-8.ucode якобы из-за того, что закодировано в iwlwifi модуль:

$ /sbin/modinfo iwlwifi | grep 'firmware:.*8000'
firmware:       iwlwifi-8000-8.ucode

решений

так что вы можете сделать об этом?

обновление до Stretch

во-первых, я бы предложил вам просто обновить Stretch: он только что вошел в стадию "мягкого замораживания", а "полное замораживание" должно произойти 5 февраля. Это означает, что не будет никаких радикальных изменений, которые делают" тестируемый " вариант Debian неудобным для использования неопытными пользователями. Stretch поставляется с ядром 4.8, поэтому ваш чипсет Wi-Fi поддерживается, и все, что вам нужно будет сделать, это включить несвободный раздел архива и установить firmware-iwlwifi пакета.

работа с backports

кроме того, вы можете включить jessie-backports раздел архива и установите ядро (доступно 4.8) и firmware-iwlwifi оттуда.

Backports включены, включая что-то вроде

deb http://httpredir.debian.org/debian/ jessie-backports main non-free

на /etc/apt/sources.list и исполнительского apt update.

вы тогда прямо скажи АПТ релиза необходимо как

# apt install linux-image-4.8.0-0.bpo.2-amd64
# apt install -t jessie-backports firmware-iwlwifi

или "pinnning" версии этих двух пакетов с именами объяснил здесь.

обновление: на моей растяжке у меня:

$ /sbin/modinfo iwlwifi|grep '8000.*ucode'
firmware:       iwlwifi-8000C--24.ucode

который, как ни странно, не коррелирует с прошивкой файлы, предоставленные firmware-iwlwifi пакета но, похоже, распространяется на эту прошивку, загруженную с сайта Intel.

0
отвечен kostix 2017-01-09 17:04:57
источник

Другие вопросы debian drivers linux