Ubuntu старое обновление 8.04 - > 12.04

(переехал изstackoverflow.com)


у меня есть компьютер под управлением старого Ubuntu 8.04 LTS.

а также 8.04, следующая версия LTS,10.04 тоже больше не поддерживается.

нет опубликованного пути прямого обновления с 8.04 -> 12.04.

здесь опубликован путь от 8.04 -> 10.04 и оттуда путь от 10.04 -> 12.04

если я попробую стандартный нормальный инструкция по обновлению, я получаю ошибку с Python. Ubuntu 8.04 входит Python 2.5. В этом сообщении об ошибке "Precise" - это псевдоним Ubuntu 12.04.

stewart@old-ubuntu-box:~$ sudo do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg'
extracting 'precise.tar.gz'
/tmp/tmpwfCGnZ/DistUpgradeMain.py:102: Warning: 'with' will become a reserved keyword in Python 2.6
Traceback (most recent call last):
  File "/tmp/tmpwfCGnZ/precise", line 3, in <module>
    from DistUpgradeMain import main
  File "/tmp/tmpwfCGnZ/DistUpgradeMain.py", line 102
    with open(fname, "a"):
            ^
SyntaxError: invalid syntax

если я попытаюсь обновить Python до 2.6 или 2.7, для поддержки запуска обновления, я нахожу проблемы с зависимостями, потому что я все еще только на 8.04.

stewart@old-ubuntu-box:~$ sudo apt-get install python2.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  python2.6: Depends: python2.6-minimal (= 2.6.5-1ubuntu7~lts1) but it is not going to be installed
             Depends: libc6 (>= 2.11) but 2.7-10ubuntu8.3 is to be installed
             Depends: libdb4.8 but it is not installable
             Depends: libreadline6 (>= 6.0) but it is not installable
             Depends: libsqlite3-0 (>= 3.6.22) but 3.4.2-2 is to be installed
E: Broken packages

круговая Уловка-22. В идеале я должен иметь возможность установить правильные версии этих сломанных зависимостей (libc6, etc), но гнать вниз, как это сделать для неподдерживаемого выпуска было неуловимым.

любые предложения, как избежать / решать эту проблему?


обновление:

мне удалось обновить Python с помощью make install из инструкции найти здесь, однако, ошибка Python на do-release-upgrade идентичны.

5
задан Community
источник

2 ответов

вы можете попробовать использовать apt-get dist-upgrade. Перед этим отредактируйте /etc/apt / sources.list:

deb http://archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted

затем sudo apt-get update и sudo apt-get dist-upgrade. Если это succeeeds, потом перезагрузка и надеюсь do-release-upgrade теперь работает на 10.04 -> 12.04.

это, вероятно, не так, как это рекомендуется делать. Я не нашел способ, как сделать do-release-upgrade для этого.

если процесс обновления по какой-то причине прерван, то commands

dpkg --configure --pending
apt-get install -f

может быть полезный.

1
отвечен J.J. Hakala 2016-01-25 03:35:32
источник

Я полагаю, что если вы попробуйте использовать подход, приведенный в https://help.ubuntu.com/community/LucidUpgrades#Upgrading_Using_the_Alternate_CD.2FDVD

испытав проблему, описанную в этом вопросе, я впоследствии смог успешно обновиться с 8.04 до 10.04, примерно следуя этим инструкциям: я записал компакт-диск образа вhttp://old-releases.ubuntu.com/releases/lucid/ubuntu-10.04.4-alternate-amd64.iso , монтируется с помощью sudo mount /dev/sr0 /cdrom (имя вашего устройства может отличаться!), и запустил обновление с sudo sh /cdrom/cdromupgrade. Это успешно завершено. Это должно также работать, если вы просто монтируете образ, используя устройство обратной связи согласно данным инструкциям.

1
отвечен William Gallafent 2016-02-04 14:29:47
источник

Другие вопросы debian installation linux ubuntu upgrade