Похожие вопросы

ошибка настройки "OpenSSL не поддерживает динамическую загрузку" при сборке bind9

при попытке построить привязку из исходных кодов,./configure завершается следующим выводом:

checking for OpenSSL library... using OpenSSL from /usr/local/lib and /usr/local/include
checking whether linking with OpenSSL works... yes
checking whether linking with OpenSSL requires -ldl... unknown
configure: error: OpenSSL has unsupported dynamic loading

У меня OpenSSL 1.1.0 e в /usr / local, и я пытаюсь построить bind 9.11.0-P3.

Как исправить эту ошибку?

5
задан Etienne Miret
источник

1 ответов

получается, что bind еще не поддерживает OpenSSL 1.1 (см. OPenssl 1.1 и Bind в списке рассылки bind-users). Установка OpenSSL 1.0.2 k и компиляция против него решили мою проблему.

3
отвечен Etienne Miret 2017-02-24 19:26:44
источник

Другие вопросы bind build openssl