Не удается установить.файлы ipk на маршрутизаторе

Я следую этому учебнику:WRT54GL В1.1 проводной стандарт IEEE 802.1 x клиент жизни пап:(буфера / нового / securew2 в wpa_supplicant, EAPOL с ТХ на RX) настроить маршрутизатор Linksys 160NL с аутентификацией. Я прошил маршрутизатор с OpenWRT Backfire 10.03.1. и это пакеты расположены здесь.

на Шаге 3 он говорит, что я должен безопасно скопировать и установить следующие пакеты на моем маршрутизаторе:

opkg install nano 
opkg install ntpclient 
opkg install wpa-supplicant 


я опрокинул следующие пакеты в папку /tmp маршрутизатора (используя pscp.exe):

nano_2.2.6-1_atheros.ipk                          --> renamed to nano.ipk
ntpclient_2007_365-4_atheros.ipk                  --> renamed to ntpclient.ipk
wpa-supplicant_20111103-2_atheros.ipk             --> renamed to supplicant.ipk
libncurses_5.7-2_atheros.ipk (dependency of nano) --> renamed to libncurses


затем я попытался установить их, подключив Putty к маршрутизатору и выполнив:

opkg install libncurses.ipk


я получил следующую ошибку:

 * pkg_hash_fetch_best_installation_candidate: Packages for libncurses found, 
   but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package libncurses.


может кто-нибудь сказать мне, что я делаю неправильно?

EDIT: я загружал пакеты из неправильной папки пакета. Я подумал, что должен загрузить их из папка" atheros", но они не являются правильными. Пакеты из папки "ar71xx" установлено без проблем. я до сих пор не знаю, почему это так. Если кто-нибудь может предложить объяснение, я был бы очень благодарен.

5
задан RunoTheDog
источник

1 ответов

Ну теперь, если вы спрашиваете "почему", ответ прост: Потому что это ваш процессор маршрутизаторов. Как связаны здесь, даже базовый образ прошивки поступает из этого каталога. Он даже должен быть в имени файла изображения.

Backfire устарел, кстати. Настоящая конюшня " регулировка ориентации" (12.09):

2
отвечен Daniel B 2014-02-18 17:29:13
источник

Другие вопросы linux networking router