Не удается установить что-либо на Kali Linux

всякий раз, когда я пытаюсь установить что-нибудь на Кали Linux, я получаю ту же ошибку.
Например, под управлением sudo apt-get -f install alien выходы:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 alien : Depends: debhelper (>= 7) but it is not going to be installed
         Depends: rpm (>= 2.4.4-2) but it is not going to be installed
         Depends: rpm2cpio but it is not going to be installed
 tcpdump : Depends: libpcap0.8 (>= 1.5.1) but 1.4.0-2 is to be installed
 tshark : Depends: libpcap0.8 (>= 1.5.1) but 1.4.0-2 is to be installed
 wireshark-common : Depends: libpcap0.8 (>= 1.5.1) but 1.4.0-2 is to be installed
 wireshark-qt : Depends: libpcap0.8 (>= 1.5.1) but 1.4.0-2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
5
задан karel
источник

1 ответов

попробуйте сделать то, что вывод говорит. Вместо sudo apt-get -f install alien для устранения проблем только с типом пакета alien:

sudo apt-get -f install  

(без упаковки)

на выходе man apt-get

-f, --fix-broken  
    Fix; attempt to correct a system with broken dependencies in place. 
    This option, when used with install/remove, can omit any packages  
    to permit APT to deduce a likely solution.
2
отвечен karel 2016-09-09 06:48:49
источник