apxs, apxs2 нигде не найти в Debian

мне сказали, что я должен apt-get установить apache2-dev, но я получаю:

apt-get install apache2-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'apache2-threaded-dev' instead of 'apache2-dev'
The following extra packages will be installed:
  apache2 apache2-mpm-prefork apache2-threaded-dev apache2.2-bin apache2.2-common comerr-dev krb5-multidev libapr1-dev
  libaprutil1-dev libdb4.8-dev libexpat1-dev libgssapi-krb5-2 libgssrpc4 libk5crypto3 libkadm5clnt-mit7 libkadm5srv-mit7
  libkdb5-4 libkrb5-3 libkrb5-dev libkrb53 libkrb5support0 libldap2-dev libmysqlclient-dev libpcre3-dev libpcrecpp0
  libpq-dev libpq5 libsqlite3-dev libssl-dev libssl0.9.8 uuid-dev zlib1g-dev
Suggested packages:
  apache2-doc apache2-suexec apache2-suexec-custom doc-base krb5-doc db4.8-doc krb5-user postgresql-doc-8.4 sqlite3-doc
The following NEW packages will be installed:
  apache2-threaded-dev comerr-dev krb5-multidev libapr1-dev libaprutil1-dev libdb4.8-dev libexpat1-dev libgssapi-krb5-2
  libgssrpc4 libk5crypto3 libkadm5clnt-mit7 libkadm5srv-mit7 libkdb5-4 libkrb5-3 libkrb5-dev libkrb5support0
  libldap2-dev libmysqlclient-dev libpcre3-dev libpcrecpp0 libpq-dev libsqlite3-dev libssl-dev uuid-dev zlib1g-dev
The following packages will be upgraded:
  apache2 apache2-mpm-prefork apache2.2-bin apache2.2-common libkrb53 libpq5 libssl0.9.8
7 upgraded, 25 newly installed, 0 to remove and 127 not upgraded.
Need to get 0 B/17.6 MB of archives.
After this operation, 39.2 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Reading changelogs... Done

и на этом все. При выдаче dpkg -l | grep apache Я:

ii  apache2                           2.2.16-6+squeeze1            Apache HTTP Server metapackage
ii  apache2-mpm-prefork               2.2.16-6+squeeze1            Apache HTTP Server - traditional non-threaded model
ii  apache2-utils                     2.2.16-6+squeeze1            utility programs for webservers
ii  apache2.2-bin                     2.2.16-6+squeeze1            Apache HTTP Server common binary files
ii  apache2.2-common                  2.2.16-6+squeeze1            Apache HTTP Server common files
ii  libapache2-mod-php5               5.2.6.dfsg.1-1+lenny9        server-side, HTML-embedded scripting language (Apache 2 module)

поэтому он не установлен... Моя проблема в том, что у меня нет файла apxs2, и я в отчаянии в данный момент. Могу ли я просто скопировать его в свой apache_dir / sbin с другого узла?

П. С.

После "Чтения Изменений.. Готово " оболочка не возвращается, я propmpt с текстом:

    krb5 (1.8+dfsg~alpha1-1) unstable; urgency=low

      This version of MIT Kerberos disables DES and 56-bit RC4 by default.
      These encryption types are generally regarded as weak; defeating them
      is well within the expected resources of some attackers.  However,
      some applications, such as OpenAFS or Kerberized NFS, still rely on
      DES.  To re-enable DES support add allow_weak_crypto=true to the
      libdefaults section of /etc/krb5.conf

     -- Sam Hartman <hartmans@debian.org>  Fri, 08 Jan 2010 22:41:14 -0500

    krb5 (1.6.dfsg.4~beta1-7) unstable; urgency=low

      * In response to MIT's 2006 announcement that Kerberos 4 is at end of
        life and no longer under development, this version of the krb5 package
        removes most support for krb4.  In particular, krb4 headers are no
        longer included; applications with krb4 support cannot be built using
        libkrb5-dev.  In addition, krb4 support has been removed from the KDC
        and user utilities.  If you do not use Kerberos 4 and do not have
        krb4-config installed, you should notice no changes.  However, if you
        do use Kerberos 4, you must transition away from Kerberos 4 before
        upgrading to this version. 
  * Downgrading from this version to a previous version can  be
    difficult because of library name changes.  Please follow these
    instructions:
      - Get the libkrb53 and libkadm55 debs you want to downgrade to
      -dpkg --force-depends --remove  libkrb5-3 libkrb5support0 libdes425-3
        libgssapi-krb5-2 libgssrpc4 libkadm5clnt5 libkadm5srv5 libkdb5-4
        libk5crypto3
      -  At this point your system has broken Kerberos libraries
      - dpkg -i libkrb53*deb libkadm55*deb (using the debs you got above)
      - aptitude -f install to fix any other packages that may be broken

так что я просто нажмите Ctrl-C и вернитесь к оболочке.

5
задан Tom
источник

2 ответов

удерживая нажатой клавишу CTRL-C и хотел apt-получить, прерывание установки.

когда apt-get показывает список изменений, он показывает их с помощью less (или любой другой пейджер, который вы установили - по умолчанию меньше). Если это меньше, что работает, просто нажмите q, чтобы продолжить. Нажатие Ctrl-C убивает меньше, но оно также убивает apt-get.

3
отвечен bdonlan 2011-10-02 05:40:34
источник

во-первых, похоже, что ваша система не может установить пакеты. Поэтому вам, возможно, придется изучить это дальше. Если в вашей системе недостаточно памяти VPS, возможно, у вас недостаточно памяти.

Я не видел apt завершить без какой-либо диагностики раньше, но мне кажется, что это то, что происходит.

однако, для вашей непосредственной проблемы, вы можете попробовать переместить apxs2 из другой коробки. Первое, что нужно сделать, это использовать ldd /usr/bin/apxs2 о системе apache2-dev установлен. Эта команда даст вам список динамических библиотек, которые нужны двоичному файлу. Вы можете проверить, существуют ли эти библиотеки в вашей целевой системе, и просто скопировать отсутствующие. Вы можете поместить их в /usr/local/lib, или модифицировать LD_LIBRARY_PATH и держать их местные. Я бы не рекомендовал копировать библиотеки в /lib или /usr/lib, хотя. Это вызовет головные боли в долгосрочной перспективе. Это не совсем решение, но может помочь в краткосрочной перспективе.

1
отвечен Dysaster 2011-10-01 21:01:40
источник

Другие вопросы apache-http-server debian debian-squeeze linux