apt-get install не работает в WSL

Windows 10 Ubuntu bash не удается установить пакеты. Всякий раз, когда я пытаюсь установить новый пакет с ниже команды, получая ту же ошибку.

root@VASI-HOME-PC:/mnt/c/Users/vadap# apt-get install atom
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package atom

Это не только с atom pacakge, но я попытался установить другие пакеты, такие как pip, а также и получил ту же ошибку.

5
задан Devoloper250
источник

2 ответов

ошибка, которую вы получаете, потому что "atom" не является частью пакетов по умолчанию, но WSL не поддерживает графические приложения, такие как Atom, поэтому он никогда не будет работать в любом случае.

я рекомендовал бы установить его для Windows, которая доступна с их сайта атом.io.

чтобы убедиться, что пакет действительно находится в системе пакетов, вы можете использовать apt search <whatever> или для более простой выход apt-cache search <whatever>.

Примечание: не делайте следующее, но для полноты картины я добавлю, как на самом деле установить его:

вам нужно добавить репозиторий atom со следующей командой:sudo add-apt-repository ppa:webupd8team/atom

после этого вы можете установить его, сначала обновив кэш поиска с помощью apt-get update и затем установка пакета с apt-get install atom.

0
отвечен Mikael Kjær 2018-09-20 09:37:58
источник

выполняется ниже 2 команд, а затем я смог установить пакеты.

sudo apt обновление

sudo apt установить python3-pip

источник https://linuxize.com/post/how-to-install-pip-on-ubuntu-18.04/

0
отвечен Devoloper250 2018-09-20 18:35:05
источник